Про WordPress

WordPress 5.6 може зламати сайти в грудні 2020 року

WordPress 5.6, що має вийти зовсім скоро, зробить jQuery Migrate Helper плагін “некорисним”, тобто таким, який не буде вирішувати проблему, для вирішення якої його створено. Це означає, що деякі сайти можуть знову зламатися.

WordPress 5.5 вийшов в серпні 2020 року і незабаром після того мільйони сайтів в інтернет зламалися. Будьте готові знову, тому що WordPress 5.6 може зробити те саме.

Один із розробників WordPress, який приймав участь в роботі над плагіном jQuery Migrate Helper, сказав на форумі підтримки, що плагін перестане виконувати свої функції , коли з’явиться вордпрес 5.6 

Той, хто все ще не вирішив питання щодо оновлення js-коду і потребує jQuery Migrate, може знову отримати проблеми після оновлення.

Чому WordPress 5.5 зламав веб-сайти

WordPress запланував покрокову модернізацію коду щодо використання jQuery. Старі версії jQuery все ще використовуються в багатьох плагінах та темах. Старі бібліотеки jQuery містять уразливості (XSS та DDoS), що може бути небезпечним для сайтів.

WordPress 5.5 – це перший крок до модернізації WordPress, що змушує всю екосистему WordPress оновити свій код і працювати з останньою та безпечнішою версією jQuery. Детальніше про проблему ми писали раніше у статті “Як виправити проблему з jQuery у WordPress 5.5“.

Чому WordPress 5.6 може зламати сайти знову

WordPress 5.6 – це другий крок модернізації щодо використання jQuery, буде оновлено бібліотеки jQuery та jQuery Migrate.

Результатом цього стане те, що сайти та їх власники, які покладаються на плагін «jQuery Migrate Helper», можуть постраждати знову.

«Першим кроком був WordPress 5.5, який за замовчуванням припинив підключення jQuery Migrate версії 1.x.

В рамках… частини другої цього процесу… буде оновлено версію jQuery до версії 3.5.1. Разом з цим, jQuery Migrate також буде оновлено до нової версії 3.3.1.

Зверніть увагу, що скрипт Migrate версії 3 не сумісний з функціями, з якими попередні версії скрипту працювали, і деякі функції jQuery, позначені раніше як застарілі, більше не будуть доступні. “

Це означає, що функціональність знову поламається для сайтів, які все ще покладаються на плагін jQuery Migrate Helper, щоб підтримувати роботу свого сайту на новій версії вордпрес.

На форумі підтримки плагіну jQuery Migrate Helper хтось запитав, чи буде плагін jQuery Migrate Helper продовжувати працювати з WordPress 5.6

“Коли надійде оновлення для WordPress 5.6?”

Розробник плагіна відповів:

“Коли з’явиться WordPress 5.6, оскільки планується оновити бібліотеку jQuery у WordPress, цей плагін залишиться некорисним і його використання буде марним…”

Багато розробників плагінів та тем оновили свій код , що він був сумісний з останньою версією jQuery, та виправили проблему. Користувачі цих продуктів не повинні постраждати.

Але є багато тем і плагінів, які більше не підтримуються, і можуть бути інші, які ще не оновили свій код. Користувачі цих продуктів, швидше за все, побачать, що їх сайти працюють не найкраще, або взагалі поламалися.

Чи зламає ваш сайт WordPress 5.6?

Якщо ви зараз використовуєте плагін Enable jQuery Migrate Helper і при вході в адміністративну панель ви бачите повідомлення про помилки, тоді так, ви можете зіткнутися з несподіваною поведінкою веб-сайту, коли WordPress оновиться до версії 5.6.

З іншого боку, якщо Enable jQuery Migrate Helper не повідомляє про помилки, це означає, що ваші теми та плагіни оновили свої бібліотеки і сумісні з свіжим jQuery, і сайт повинен функціонувати належним чином.

Залишити відповідь

Ваша e-mail адреса не оприлюднюватиметься. Обов’язкові поля позначені *


Сьогодні діє
промокод
BLACKFRIDAY